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Как работать с SLSportTitler 

Общее описание 

 

Программное обеспечение включает 4 части: 

1) SLSportDataBaseService – сервер, обеспечивающий работу с базой данных. 

2) SLSportTeamsEditor – редактор базы данных (статическая информация – текст, фото). 

3) SLIceHockeyReferee / SLBasketballFIBAReferee / SLFootballReferee – программа для 

интеграции с табло или ввода динамической информации вручную (игровое время, голы, 

удаления, буллиты). 

4) SLSportTitler – рабочее место оператора спортивной графики (титровальщик). 

Дизайн создается заранее в программе Microsoft Expression Blend (как правило, дизайнером из 

компании SoftLab-NSK).  

Для разных видов спорта необходимо использовать разные плагины (программные модули, 

расположенные в папке с программой SLSportTitler.exe) и разные версии программы 

SLIceHockeyReferee.exe (например, SLBasketballFIBAReferee.exe). 

Для одного и того же вида спорта можно использовать разные дизайны. Так, для игр КХЛ, МХЛ и 

ВХЛ требования к объему показываемой информации существенно различаются. Например, 

статистика по игрокам за текущий сезон обязательна в КХЛ, и такую статистику можно скачать с 

сайта КХЛ (информация обновляется каждое утро). Для других лиг информацию получить 

неоткуда.  Однако, показывать титр с пустой информацией нельзя, соответственно, его нужно 

изменить (например, оставив в титре только рост и вес игрока, а остальные поля удалить совсем). 

Кроме того, дизайн может изменяться каждый сезон. В результате, дизайн делается под 

конкретный сезон конкретного вида спорта. 
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Настройка ПО 

Основная часть информации содержится в базе данных. Для ее редактирования необходимо 

использовать редактор базы данных SLSportTeamsEditor. Пути к изображениям в базе данных 

сохраняются относительно файла базы данных *.TitleDB. В программе SLSportTitler загружается 

проект *.SLSportTitleCfg, в котором задаются все ссылки на дизайн (пути к дизайну указываются 

относительно папки с проектом). Таким образом, для корректной работы с изображениями 

требуется, чтобы файл с базой данных (*.TitleDB) и файл с проектом (*.SLSportTitleCfg) лежали в 

одной и той же папке.  

Описание периодов (количество периодов и их длительности) задается в XML-подобном файле 

описания игры, задаваемым в командной строке и лежащим рядом приложением SL…Referee.exe. 

Например, для хоккея это файл IceHockey.xml рядом с модулем SLIceHockeyReferee.exe. Формат 

файла: 
<GameDesc PeriodsCount="7" ReverseTime="true" MaxPenaltyCnt="2"> 

<Period Duration="20"/> 

<Period Duration="20"/> 

<Period Duration="20"/> 

<Period Duration="5"/> 

<Period Duration="1"/> 

</GameDesc>  

В тэге «GameDesc» задаются параметры игры. Параметр «ReverseTime» равен «true». Это 

означает, что время показывается в сторону уменьшения (от 20:00 до 00:00). Параметр 

«PeriodsCount» задает количество периодов в игре. Для каждого периода задается 

дополнительный тэг «Period», у которого задается параметр «Duration» – длительность периода (в 

минутах). В приведенном примере параметр «PeriodsCount» равен «5». Это указывает, что в игре 

используется 5 периодов. Первые три периода по 20 минут, четвертый – 5 минут, а пятый период 

нужен только для того, чтобы показывать надписи по окончанию игры. Параметр «MaxPenaltyCnt» 

задает максимальное количество одновременных удалений в игре. 

Для волейбола формат описания содержит дополнительные параметры: 
<GameDesc ShortCut="84" PeriodsCount="5" TimeoutsMax="2" FoulsMax="4" GamesToWin="3" 

ScoreDeltaToWin="2"> 

<Period Duration="20" ScoreToWin="25"/> 

<Period Duration="20" ScoreToWin="25"/> 

<Period Duration="20" ScoreToWin="25"/> 

<Period Duration="20" ScoreToWin="25"/> 

<Period Duration="99" ScoreToWin="15"/> 

</GameDesc> 

В описании периода есть параметр «ScoreToWin», определяющий количество очков, достаточное 

для выигрыша в этом периоде. В описании игры параметр «GamesToWin» задает число 

выигранных периодов, достаточное для победы в игре, а параметр «ScoreDeltaToWin» задает 

минимальную разницу в выигранных периодах. Параметр «TimeoutsMax» задает максимальное 

число таймаутов,  а параметр «FoulsMax» –максимальное число фолов. 

Программа SLSportTeamsEditor содержит конфигурационные файлы, в которых описаны колонки 

разных таблиц. Разные виды спорта или разные типы дизайна показывают титры с разными 

данными, поэтому конфигурационные файлы должны быть разными. Эти файлы всегда должны 

лежать в подпапке CSV относительно полного имени файла с базой данных. 

В титрах используются надписи, которые нужно переводить на русский или английский язык. Все 

такие надписи также располагаются в подпапке CSV. Русский текст задается в файле 

TranslateRus.csv, а английский – в TranslateEng.csv. Чтобы переключить язык необходимо в 
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программе SLSportTeamsEditor загрузить нужный перевод в таблицу «Translation». В этой же 

таблице указываются названия периодов в ячейках, имеющих название «Period_N_NameM», где N 

– номер периода, а M – номер названия. Для примера рассмотрим показ названия периода в 

титре UpScore, где используется два имени Name1 и Name2. Для первого периода нужно указать 

Period_1_Name1 = «1» и Period_1_Name2 = «ST», чтобы название периода показалось как «1ST». 

Для 4-го периода нужно указать Period_4_Name1 = «OT» и Period_4_Name2 = «», чтобы название 

периода показалось как «OT». Имя Name3 используется в титре «DownScore», а имея Name4 – в 

«StatGame». Здесь же могут встречаться регулярные выражения, необходимые для правильного 

склонения окончаний, например для FIBA требуется подстановка вместо строки 

"Regex+SzPoints+Player_PTS" выражения "[ ]+; ;[1];Point;;Points;;", чтобы в титрах было написано «1 

Point» или «2 Points». Для коррекции перевода рекомендуется исправлять копию файла, чтобы 

при некорректном сохранении не были безвозвратно потеряны оригинальные данные. 

ВНИМАНИЕ! В системе используется одна текущая база данных, поэтому при смене вида спорта 

нужно обязательно изменить текущую базу данных. Для этого нужно в соответствующей папке 

создать новую базу или открыть созданную ранее базу и обязательно сохранить ее (выбрать 

меню File->Save или File->Save As). Только после сохранения базы можно запускать программы 

SLIceHockeyReferee.exe и SLSportTitler.exe. 

В командной строке программы SLSportTitler можно указать имя сохраненной конфигурации с 

дизайном конкретного вида спорта. Рекомендуется создавать на рабочем столе ярлыки на 

программу SLSportTitler с разными дизайнами в командной строке.  

В командной строке программы SLIceHockeyReferee.exe и SLBasketballFIBAReferee.exe нужно 

указать файл описания игры. 

В командной строке программы SLSportTeamsEditor.exe можно указать произвольное слово, 

которое будет использоваться как ключ при сохранении/восстановлении настроек. Например, 

если сделать два ярлыка с параметрами «SLSportTeamsEditor.exe KHL» и «SLSportTeamsEditor.exe 

VHL», то при старте каждого из ярлыков будут открываться разные базы. Однако в любом случае 

необходимо сохранить открытую базу, чтобы она стала текущей для других программ. 

Таким образом, для каждого вида спорта имеет смысл создавать по три ярлыка: 

1) SLSportTitler с файлом дизайна этого вида спорта, 

2) SLIceHockeyReferee / SLBasketballFIBAReferee / SLFootballReferee с описанием периодов 

этого вида спорта, 

3) SLSportTeamsEditor с соответствующими конфигурационными файлами. 

 

ВНИМАНИЕ: Если в папке с дизайном «Design» есть подпапка «Font», то необходимо 

предварительно установить все шрифты из этой папки на компьютер! 
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Заполнение базы данных 

Перед игрой необходимо заполнить все таблицы базы данных в программе SLSportTeamsEditor. 

 

Таблица «Game» содержит поля, не зависящие от игрока или команды. Например, это название 

стадиона, сезона, температура на улице, логотип лиги и другое. Конфигурационный файл – 

GameInfo.csv. 

Таблица «Translation» содержит строки, в которой указаны все текстовые подписи в разных 

дизайнах, которые не меняются в зависимости от игрока, команды или стадиона. Файл с 

переводами – TranslateEng.csv и TranslateRus.csv. 

Таблица «First team info» содержит информацию о первой (левой) команде – название команды, 

логотип, ФИО тренера и другое. Конфигурационный файл – TeamInfo.csv. 

Таблица «Second team info» содержит информацию о второй (правой) команде. 

Конфигурационный файл – TeamInfo.csv. 

Таблица «First team players» содержит информацию об игроках первой команды – номер, 

фамилия и имя, фото, вес, рост, статистика и другое. Конфигурационный файл – TeamPlayers.csv. 

Таблица «Second team players» содержит информацию об игроках второй команды. 

Конфигурационный файл – TeamPlayers.csv. 
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ВНИМАНИЕ!!! Рекомендуется все надписи делать большими буквами! 

Редактирование данных может выполняться прямо в программе – по двойному щелчку на ячейке. 

Если данные текстовые, то запустится встроенный текстовый редактор. По окончанию 

редактирования нужно щелкнуть в другую ячейку, чтобы встроенный текстовый редактор 

закрылся и записал данные в ячейку. Если это изображение, то вызовется стандартный диалог 

выбора файла. После выбора файла в ячейке запоминается относительный путь к файлу. Путь 

указывается относительно текущего файла базы данных, поэтому сразу после создания новой 

базы данных нужно сначала сохранить ее на диск, а только потом редактировать данные в базе. 

В каждой из таблиц есть три кнопки: ,  и . Кнопка  очищает таблицу (то есть создает пустые 

колонки, описанные в конфигурационном файле этой таблицы). Кнопка  вызывает диалог 

выбора файла и загружает из него таблицу (при этом состав колонок может не совпадать с 

конфигурационным файлом этой таблицы). Кнопка  вызывает диалог выбора файла и 

записывает в него выбранную таблицу. 

С сайта КХЛ можно получать описание команды по кнопке  . Вначале возникает диалог выбора 

команды. После выбора команды программа создает отдельную папку на диске по имени 

выбранной команды (в подпапке «Base»), скачивает в нее всю информацию (описание команды и 

описание всех игроков команды, включая фотографии игроков, которые должны быть скачаны 

заранее в папку «Base\PhotoPLAYERS»), создает файлы TeamInfo.csv и TeamPlayers.csv и заполняет 

две таблицы – информацию о команде и информацию об игроках команды. Для того чтобы 

кнопка  работала корректно, необходимо вначале настроить login и password для доступа к 

сайту КХЛ, для чего нужно вызвать меню Edit->Settings. Папка «Base\PhotoPLAYERS» обязана быть 

создана заранее. Если фотографий в папке нет, то программа сама скачивает фотографии с сайта 

КХЛ. Однако это могут быть JPG-файлы без прозрачности, поэтому они могут выглядеть некрсиво. 

Рекомендуется все JPG-файлы преобразовать в PNG-файлы с прозрачностью, вырезав фон за 

спортсменом. 

В таблицах с информацией об игроках команды есть кнопки  и . Кнопка  создает новую 

строку в таблице, а кнопка  удаляет текущую строку из таблицы. Первая колонка «#» задает 

порядок, в котором будут загружаться игроки в программе SLSportTitler. 

ВНИМАНИЕ! После редактирования данных не забудьте каждый раз нажимать кнопку  (меню 

File->Save) для сохранения информации в базу данных. Также не забудьте, что если Вы 

редактировали текстовые данные, то нужно обязательно сначала щелкнуть в любую другую 

ячейку, чтобы встроенный текстовый редактор записал редактируемые данные в ячейку базы 

данных.  
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Отображение титров 

Программа SLSportTitler позволяет одной кнопкой (одним или двумя кликами) показать готовое 

экранное поле (титр). Для каждого вида спорта поставляется дизайн с настроенным проектом, в 

котором сконфигурирован конкретный набор кнопок, например такой: 

 

Каждая кнопка показывает конкретный титр (одну экранную форму), в которой нужные поля 

заполнены текущими данными из базы данных или информацией из программы ввода 

динамических данных. Кнопка может находиться в одном следующих состояний: 

1) Серая – титр выключен, 

2) Красная – титр готовится к показу (и показывается в окне предварительного просмотра), 

3) Зеленая – титр готов к показу в эфире или уже показывается в эфире. 

Нормальное состояние кнопки – серое. По первому щелчку на кнопку она становится красной и 

показывает титр в окне предварительного просмотра. По окончанию анимации в окне 

предварительного просмотра обычно кнопка меняет цвет на зеленый, что означает, что титр готов 

к показу – можно нажимать кнопку Take для выдачи титра в эфир. Некоторые кнопки могут 

автоматически выдавать титр в эфир без показа в окне предварительного просмотра, например, 

кнопка UpScore (показ верхнего счета в хоккее). По следующему щелчку по кнопке (или по 

команде Stop all) титр уходит из эфира. По команде Abort all титр просто быстро гаснет 

(выполняется FadeOut без выполнения финальной анимации).  

Часть кнопок используют информацию о текущей команде или о текущем игроке, выбранном в 

списке игроков: 

 

При изменении данных в базе (и сохранении их кнопкой ) следующий показ титра будет 

отображаться уже с новыми данными игроков/комманд. Для обновления информации в списке 

игроков нужно нажать кнопку Update data. Данные из таблиц «Game» и «Translation»  могут 

кэшироваться и не обновляться до перезапуска программы SLSportTitler. 

Чтобы изменить названия кнопок, их расположение и размеры, горячие клавиши, GPI-события или 

другие параметры, необходимо перейти в режим редактирования настроек проекта. Для этого 
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нужно выполнить команду меню File->Stop и вызвать диалог конфигурации кнопок командой 

меню Options->Configure buttons. В диалоге у каждой кнопки можно задать горячую клавишу, по 

нажатию которой будет готовиться показ этого титра. В меню Options->Configure special buttons 

можно сконфигурировать горячие клавиши для команд управлением выдачей в эфир 

подготовленных кнопок.  

Чтобы выбрать устройство отображения, нужно выбрать команду меню Options->Options. В 

диалоге Options нужно в списке Board type выбрать FDExt, а в списке Board number выбрать одну 

из доступных плат.  

Показ титров требует очень большого объема памяти. Рекомендуется использовать не менее 16 

гигабайт оперативной памяти. 
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Ввод динамической информации 

Программа SLIceHockeyReferee позволяет вводить игровое время, номер периода, голы, буллиты 

и удаления игроков.  

 

При старте программы названия команд берутся из текущей базы данных, сохраненной 

последний раз программой SLSportTeamsEditor. Для сброса состояния игры в начало необходимо 

выполнить команду меню File->Restart.  

Выпадающие списки под названиями команд показывают распределение готов по периодам. 

Ниже расположены два текстовых поля для ввода счета в текущем периоде. Обратите внимание, 

что это счет только в текущем периоде, а не во всей игре! Слева и справа расположены кнопки для 

увеличения счета. 

Ниже показывается текущий период и еще ниже – текущее время в периоде. Копка Start/Stop 

продолжает/останавливает ход времени игровых часов. Кнопка Correct Time позволяет изменить 

игровое время (только когда игра остановлена). Кнопки «+» и «–» справа и слева от текущего 

времени позволяют увеличить/уменьшить текущее время на одну секунду прямо во время игры. 



9 

 

Копка Shootouts вызывает диалог управления буллитами: 

 

Ниже располагается блок управления удалениями. Кнопки Add penalty позволяют добавить 

очередное удаление для соответствующей команды. Кнопка Remove penalty отменяет выбранное 

удаление. Кнопки «+», «–» и Correct Time позволяют изменить время у выбранного удаления. 

Команда меню File->Config позволяет автоматизировать управление временем (и, возможно, 

другими параметрами). Если в системе настроено подключение к табло, то можно включить 

галочки Use score-board (time & score info), Use score-board goals info, Use score-board penalties info. 

Для подключения к табло обращайтесь в службу технической поддержки СофтЛаб-НСК. Здесь же 

можно настроить старт/останов таймера игрового времени по GPI-событиям, вызвав диалог 

выбора GPI событий кнопкой Config GPI. 

В хоккее титры UpScore и Bullits автоматически изменяют данные в текущем изображении при 

изменении игрового времени, номера периода, числа голов, удалении игроков или буллитов 

(shootouts). Остальные титры не меняют изображения при изменении соответствующих данных в 

программе SLIceHockeyReferee, поэтому для отображения новых данных нужно убрать титр из 

эфира и показать его снова с новыми данными. 
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Особенности заполнения данных для игр КХЛ 

Кнопка  в программе SLSportTeamsEditor позволяет импортировать статистику для выбранной 

команды. Один раз необходимо настроить доступ к серверу статистики КХЛ. Для этого нужно 

вызвать диалог настроек командой меню Edit->Settings: 

 

В поле Login и Passwordнужно указать логин и пароль для доступа к сайту статистики 

«http://stat2tv.khl.ru» (их необходимо получать у КХЛ индивидуально). Настройки достаточно 

указать один раз. 

Далее при нажатии на кнопку  откроется окно выбора команды: 
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В верхнем левом углу можно выбрать язык, на котором будет браться информация из базы 

(фамилии игроков, названия команд). 

После импорта необходимо выполнить следующие обязательные действия: 

1) Выбрать логотипы команд из папки «Base\Logo». 

2) Выбрать цвета команд (цветной фон под логотип) из папки «Base\Colors». 

3) Указать фамилию и имя тренера команды (текст должен быть набран большими буквами). 

4) Удалить из списка «лишних» игроков (не заявленных на текущую игру). 

5) Указать стартовую пятерку в колонке «Pos5». Под номером 1 должен быть выбран левый 

нападающий, под номером 2 – центральный нападающий, 3 – правый нападающий, 4 – 

левый защитник, 5 – правый защитник, 6 – вратарь. 

6) Сохранить базу. 

7) В процессе игры необходимо заполнять статистику команд в таблицах «First team info» и 

«Second team info» в колонках «Shots», «Faceoffs», «Penalty», «Powerplay» и «Shorthanded» 

(эта информация показывается в титре «StatGame»), либо не показывать титр «StatGame». 

Основной дизайн «KHL-2016-WithPhoto.SLSportTitleCfg» предполагает использование фотографий 

игроков и тренера. При загрузке информации о команде программа загружает в папку 

«Base\PhotoPLAYERS» все фотографии игроков с сайта KHL. Изображения игроков на сайте 

хранятся в формате JPG (без прозрачности), поэтому отображение в титрах таких фотографий 

выглядит некрасиво. Рекомендуется преобразовать все фотографии в формат PNG с 

прозрачностью (вырезать фон за игроком) и положить PNG файлы в ту же папку вместо JPG-

файлов. Все фотографии должны быть высотой 400 пикселей и шириной не более 400 пикселей 

(например, 320х400). Поскольку на сайте «http://stat2tv.khl.ru» есть только фотографии игроков, то 

фотография тренера не загружается автоматически, ее нужно скачивать отдельно. Одновременно 

со скачиваем фотографий в рядом с базой создается CSV-файл с названием команды. В этом 

файле сопоставляются номер игрока в базе статистики КХЛ (первая колонка), нагрудный номер 

игрока в команде (вторая колонка), фамилия и имя на русском языке(третья колонка), фамилия и 

имя на английском языке(четвертая колонка) и название команды (пятая колонка). Этот файл 

позволяет дизайнеру преобразовывать JPG-файлы только для «нужных» игроков конкретной 

команды. После копирования фотографий с прозрачностью в папку «Base\PhotoPLAYERS» можно 

загрузить описание команды заново – программа сначала проверяет наличие в папке 

«Base\PhotoPLAYERS» PNG-файла, если его нет, то проверяет наличие в этой же папке JPG-файла, и 

если его тоже нет, то скачивает файл с сайта КХЛ. Если же файл есть, то в локальную базу 

подставляется ссылка на найденный файл. 

Дизайн «KHL-2016-NoPhoto.SLSportTitleCfg» не использует фотографий, поэтому при его 

использовании можно ничего не делать с файлами фотографий. 
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Особенности заполнения данных для игр FIBA 

Для игр FIBA необходимо запустить программу SLSportTeamsEditor с параметром /FIBA в 

командной строке. В этом случае в основном тулбаре появится дополнительная кнопка  для 

импорта данных из лог-файла с текущей статистикой игры. При первом нажатии на эту кнопку 

вызовется диалог настройки текущей статистики: 

 
Необходимо выбрать файл со статистикой (кнопка справа «…»). 

Если включить опцию «Load information about teams and players from Log-file», то при 

последующем нажатии на кнопку  обновится вся информация о командах и игроках. То есть 

текущая информация будет полностью удалена и заменена новым списком игроков. 

Рекомендуется включать эту опцию один раз перед игрой для заполнения состава команд и далее 

ее не включать. 

Опция «The single circle fro read from Log-file» переключает режим работы с файлом статистики. 

Если опция выключена, то при нажатии на кнопку  программа будет автоматически обновлять 

информацию из файла статистики до тех пор, пока кнопка  не будет отжата. Если же опция 

включена, то по нажатия кнопки  будет выполняться только одно обращение к файлу 

статистики. Непрерывное обращение к файлу статистики может приводить к конфликтам к доступу 

к файлу статистики, поэтому рекомендуется включать опцию и вручную обновлять информацию 

при необходимости показать текущую игровую статистику. В нижней части экрана показывается 

индикатор . Зеленый цвет индикатора  означает, что в текущий момент файл статистики 

успешно читается. Красный цвет индикатора  означает, что в текущий момент нет доступа к 

файлу статистики. 

После первого заполнения состава команды необходимо определить недостающие параметры:  

1) Рост (колонка «Height»). 

2) Возраст (колонка «Age»). 

3) Амплуа (колонка «Role»). 

4) Задать в колонках «GP3pr», «GP2pr» и «GP1pr» статистику игрока в турнире (3 pts, 2 pts, и 

FT) в процентах. Если эти числа не заданы, то нельзя показывать титр «Tournament». 

5) Задать «1» в колонке «Pos» для всех членов команды. 

6) Задать цифры от 1 до 6 для стартовой группы. 

В конец базы можно добавлять произвольных людей, но у них нельзя указывать «1» в поле «Pos». 
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Особенности показа верхнего счета для игр FIBA и Handball 

В дизайнах для FIBA и для Handball заложена поддержка показа динамической информации о 

последнем игроке, забившем гол или получившем предупреждение (фол). Правила показа этих 

анимаций очень простые – они показываются автоматически без участия оператора, если выбран 

показ «UpScore+Top». Кнопка «UpScore» не показывает анимации про игрока. Длительность 

анимации около пяти секунд. Если во время показа одной анимации от табло приходит новая 

информация, то текущая анимация прерывается, а показывается новая анимация, но не с начала, 

а с некоторого кадра «N». Если показано меньше половины анимации, то новая анимация 

стартует с текущего номера кадра. Иначе, новая анимация стартует с половины длительности. 

Первый пример: судья указал, что гол забил игрок №5. От табло пришла информация, что у игрока 

№5 очки равны единице. Соответственно, начался показ анимации для игрока №5. Но судья тут 

же исправил номер игрока на №4. От табло пришло сначала сообщение, что у игрока №5 очки 

равны нулю, и тут же второе сообщение, что у игрока №4 очки равны единице. Визуально данные 

в анимации будут изменены, а она сама продолжит показ как будто ничего не произошло. 

Другой пример: сначала игрок №5 забил гол, а через 4 секунды игрок №6 другой команды 

заработал фол. В этом случае анимация изменения очков игрока №5 будет показана почти вся (4 

секунды), а затем все данные изменятся, плашка простоит еще 2 секунды и уйдет с экрана. То есть 

не будет показано завершения первой анимации («улета») и не будет показано начала второй 

анимации («влета»).  

Анимации про последнего игрока не будут показываться, если табло не поддерживает передачу 

соответствующих данных. Некоторые табло передают данные не по номеру игрока, а по его 

индексу. В этом случае необходимо в базе данных заводить колонку «ButtonId», в которую нужно 

прописывать индекс кнопки на табло для конкретного игрока в каждой команде. По умолчанию, 

такая колонка заведена в дизайне FIBA. 

 


