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Notice

The information in this document is subject to change without prior notice in order to improve 
reliability, design, or function and does not represent a commitment on the part of this company.

In no event will we be liable for direct, indirect, special, incidental, or consequential damages 
arising out of the use or the inability to use the product or documentation, even if advised of the 
possibility of such damages.

Copyright © 1997 - 2013 SoftLab-NSK Ltd.
All Rights Reserved.

No part of this reference manual may be reproduced or transmitted in any form or by any means 
without the prior written permission of this company.

Throughout this manual, we make reference to product names that are trademarks of other 
companies. We are using these names for identification purposes only, with no intention of 
infringement of the trademarks.

FCC Information

FCC ID: 

This equipment has been tested and found to comply with the limits for a Class B digital device, 
pursuant to Part 15 of the FCC Rules.  These limits are designed to provide reasonable protection 
against harmful interference in a residential installation.  This equipment generates uses and can 
radiate radio frequency energy and, if not installed and used in accordance with the instructions, 
may cause harmful interference to radio communications.  However, there is no guarantee that 
interference will not occur in a particular installation.  If this equipment does cause harmful 
interference to radio or television reception, which can be determined by turning the equipment 
off and on, the user is encouraged to try to correct the interference by one or more of the following 
measures:

Reorient or relocate the receiving antenna.
Increase the separation between the equipment and receiver.
Connect the equipment into an outlet on a circuit different from that to which the receiver is 
connected.
Consult the dealer or an experienced radio/TV technician for help.

Shielded cables and I/O cards must be used for this equipment to comply with the relevant FCC 
regulations. Changes or modifications not expressly approved in writing by SoftLab-NSK Ltd. may 
void the user’s authority to operate this equipment.

Limited Warranty

Our company warrants this product against defects in materials and workmanship for a period of 
one year from the date of purchase.  During the warranty period, products determined by us to be 
defective in form or function will be repaired or replaced at our option, at no charge.  This warranty 
does not apply if the product has been damaged by accident, abuse, misuse, or as a result of service 
or modification other than by us.

This warranty is in lieu of any other warranty expressed or implied.  In no event shall we be held 
liable for incidental or consequential damages, such as lost revenue or lost business opportunities 
arising from the purchase of this product.

 



Table of Contents

Introduction .........................................................................................................................5

General Information ........................................................................................................6
1. Set of Programs .......................................................................................................6
2. General Scheme of Dealing with Programs .............................................7

Instruction  ................................................................................................................8

Before a Game ....................................................................................................................8
1. Launch of the System ..........................................................................................8
2. Start of Data Capturing Into Storages .........................................................9
3. Launch of FDReplayMachine Console ..................................................... 11
4. The FDReplayMachine Console Program Window After 

Launch  
and The First Steps  ............................................................................................. 12

During Game: Main Operator Actions ................................................................ 15
1. General Information .......................................................................................... 15
2. Marking of Event When It Happens .......................................................... 16

1. Marking Without Type Indication ....................................................... 16
2. Marking With Type Indication (Special Event) ............................. 18

3. Correction of Events .......................................................................................... 19
1. Correction of Current Event ................................................................... 19
2. Changing of Type of Any Event ........................................................... 22

4. Adjusting and Launching of Replays ........................................................ 24
1. Brief Instruction ........................................................................................... 24
2. Detailed Instruction ................................................................................... 25

After a Game ..................................................................................................................... 30
1. Stop of Game Recording ................................................................................. 30
2. Adding of New Event Later Real Time ...................................................... 31
3. Creation of Video Report ................................................................................. 34
4. Finish Working with the FDReplayMachine Console Program ... 35

Navigating Storages ..................................................................................................... 36
1. Moving to Event .................................................................................................. 36
2. Moving to Necessary Time ............................................................................. 37
3. Moving to Storage Border .............................................................................. 38
4. Moving to Period Start ..................................................................................... 39
5. Navigating Current Position Via Frames ................................................. 39
6. Navigating Several Seconds Back From Mark of Current Event . 41
7. Moving At Event Marking ............................................................................... 41

Working With Backgrounds/Video Introductions ......................................... 43



1. General Information .......................................................................................... 43
2. Customizing of Introductions ...................................................................... 43
3. Control Over Introductions ............................................................................ 47

Overlaying Game Titles (Logotype) ...................................................................... 48

FDReplayMachine Console. Program Interface  ..........................................50

Main Program Window ............................................................................................... 50
1. Appearance ............................................................................................................ 50
2. Playing Time Timer ............................................................................................. 51
3. Indicators of Current Position ....................................................................... 52
4. Elements to Work With Events  .................................................................... 53

1. Table With Events List  .............................................................................. 53
2. Current Event Indicator  ........................................................................... 54
3. Buttons to Mark and Correct Events ................................................. 55

5. Preview Windows ................................................................................................ 55
1. Small Preview Windows  .......................................................................... 56
2. Large Preview Window  ........................................................................... 57
3. Additional Preview Window  ................................................................. 57
4. Window Size and Labels  ......................................................................... 58

6. Elements To Control Replays Speed and Direction ........................... 59
7. Buttons To Control Intros ................................................................................ 60
8. Control Elements and Replays Indicators .............................................. 60

Main Menu ......................................................................................................................... 62

Interface Customizing ................................................................................................. 68
1. Language ................................................................................................................ 68
2. Information in Title Bar Area ......................................................................... 69
3. Logotype ................................................................................................................. 70
4. Size of Buttons and Preview Windows ..................................................... 71
5. Displaying of Time .............................................................................................. 72

Default Settings .............................................................................................................. 73

Customizing of Working Mode ..........................................................................74

Timing Via Board............................................................................................................. 74

Preview Mode .................................................................................................................. 76

Specifying of Board for Replays Playback ......................................................... 79

Data Buffer in Operative Memory ......................................................................... 81

Use of Processors and Priority ................................................................................. 83

Interaction With External Devices Via GPI ......................................................... 85

External Consoles ........................................................................................................... 88



5

Introduction

The «Forward Goalkeeper» system is a hardware/software 
complex developed for organizing of instant replay of moments 
happened during sport game and other events. The system 
works in a real-time mode. 

The system allows organizing multichannel recording of video 
and audio data into storages (up to 10 channels), preparing and 
replaying the most interesting events of match.

This guide is intended for operator who manages the «Forward 
Goalkeeper» slow motion replay system. The document 
describes workflows before, during and after match. 
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General Information

1. Set of Programs
The main set of needed programs includes the 
FDReplayCapture and FDReplayMachineConsole programs. 

The FDReplayCapture program is used for capturing video 
and audio data from board inputs into storages. The program 
allows to customize capture lines, launch/stop capture into 
storages (more information on this issue you can find in the 
«FDPostPlayCapture. Application for input of video and audio 
data into PostPlay storages, dealing with storages using the 
FD322, FD422, FD842 boards» user's guide).

Note: Previous versions of the system are based on the FD300 board. In 
such versions FDReplayVideoIn program is used to capture signal 
into storages and control them. For more details see the corresponding 
user's guide. 

The FDReplayMachineConsole program is used to control 
instant replays. The program allows:

 ● marking the most interesting moments in recorded 
sport game in a real-time mode, during the game and 
when it is over;

 ● playback of replays during the game;
 ● preparing of a playlist and its playback in breaks;
 ● exporting of a video report from playlist.

Note: For solutions with a different quantity of capture lines different 
variants of programs are used: FDReplayMachineConsole  
(up to 4 capture lines) and FDReplayMachineConsole8ch (more than 4 
capture lines).
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http://www.softlab-nsk.com/forward/docs/en_postplay_capture.pdf
http://www.softlab-nsk.com/forward/docs/en_postplay_capture.pdf
http://www.softlab-nsk.com/forward/docs/en_postplay_capture.pdf
http://www.softlab-nsk.com/forward/docs/en_rm_videoin.pdf
http://www.softlab-nsk.com/forward/docs/en_rm_videoin.pdf
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2. General Scheme of Dealing with Programs

 
Before match

 
Operator:
1. Launches the FDReplayCapture program (or the FDReplayVideoIn  
program) and starts capturing of data into storages (up to 10 capture lines, 
depending on used solution);
2. Launches the FDReplayMachine Console program. 

 
During match

 
1. The match is automatically recorded into storages by means of the  
FDReplayCapture program (or the FDReplayVideoIn program).  

2. Operator deals with the FDReplayMachine Console program:
– marks interesting events during match;
– controls over replaying of marked events.

 
After match

 
Operator deals with the programs:
1. FDReplayCapture (or the FDReplayVideoIn program):

 ● stops capturing of data into storages;
 ● stops work of the program. 

2. FDReplayMachine Console:
 ● creates video report with important events of the match;
 ● stops work of the program. 

3. RPMStorageManager:
 ● moves recording of the match from storages into archive;
 ● stops work of the program.

This document provides with a detailed description of operator 
actions given above.

A full scheme of dealing with the «Forward Goalkeeper» system 
you can find in the «Forward Goalkeeper System. Scheme of 
Use» guide (the document is currently under development).
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Instruction 

Before a Game

1. Launch of the System
1. Turn PC on.

2. Wait till the pop-up message on launching of the PostPlay 
Service appears above the icon of PostPlay Indicator in the 
Windows taskbar notification area: PostPlay Service is Run-
ning.

Note: 1. PostPlay Indicator is a program included in the «Forward 
Goalkeeper» software set. It is launched automatically when Windows 
is started.
2. PostPlay Service is a service program of the «Forward Goalkeeper» 
system.
The PostPlay Service and the PostPlay Indicator applications are 
components necessary for working of the «Forward Goalkeeper» 
system.
3. Mentioned programs (1, 2) are launched automatically at starting 
of Windows if default settings are active.

3. Shortcuts of the main programs of the «Forward 
Goalkeeper» system are located on the desktop:

 ● FDConfig2 is a program for customizing of boards for 
data input/output;

 ● FDReplayCapture is a program for customizing 
and control capturing of video and audio data into 
storages;
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 ● ReplayMachineConsole (ReplayMachineConsole8ch) is  
a program to control replays.

 

Note: Deal with another programs if the solution is based on the FD300 
boards: in this case FDConfiguration program is used for customizing 
of boards; FDVideoIn #1, FDVideoIn #2 are used for capturing of 
signal into storages. 

4. The Start > Programs > ForwardGoalkeeper menu has a set of 
commands to open programs included in the software set.

2. Start of Data Capturing Into Storages

Note: The instruction is useful in cases when all preliminary settings are 
made, needed storages are created and capture lines are customized. 
If settings are not made or some parameters you wish to change then 
see corresponding sections of the present instruction.
More information on dealing with the FDReplayCapture program you 
can find in the «FDPostPlayCapture. Input of Audio and Video Data 
Into Storages, Dealing with Storages Using the FD322, FD422, FD842 
Boards» user’s guide. 

1. Double-click the FDReplayCapture shortcut (1).

1
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http://www.softlab-nsk.com/forward/docs/en_postplay_capture.pdf
http://www.softlab-nsk.com/forward/docs/en_postplay_capture.pdf
http://www.softlab-nsk.com/forward/docs/en_postplay_capture.pdf
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2. Program window with a list of customized capture lines 
appears (2). Click Start (3) to start capturing signal from 
cameras (connected to boards inputs) into storages. 

2

3

3. Capturing is started. The Running status for each line in 
the State column (4) appears. Preview area displays frames 
of captured video (frames are updated several times per 
second).

54 6

4. Minimize the FDReplayCapture program window by 
clicking one of the buttons (5, 6). 
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 Capturing is not interrupted. The program continues working.  
The (7) program icon appears in Windows taskbar notification 
area.

7

3. Launch of FDReplayMachine Console
1. Start one of the programs by double-clicking its shortcut 

located on desktop depending on quantity of capture lines:
 ● 4 lines or less – ReplayMachineConsole (1);
 ● more than 4 lines – ReplayMachineConsole8ch (2). 

1 2

Note: The following information is given basing on example with 2 capture 
lines in the ReplayMachine Console program. 

2. Be sure that you selected that storages where data is 
captured to (3). Data was started to capture into these 
storages at the previous step. You can use the On/Off  
buttons (4) that are active.

5

34

 Selection of storages is usually made in advance. It it 
recommended not to change their selection. Click OK (5) to 
pass to the next step. 
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4. The FDReplayMachine Console Program Window After Launch  
and The First Steps 

1. The following information is displayed in the program 
window before any actions are implemented:

 ● time from start (1) is a time period from start of 
program launch;

 ● Current Time indicator (2) displays time that corresponds 
to the current position of video previewing; 

 ● current previewing position is at the beginning of 
storage, it corresponds to the 00:00:00.00 mark (3);

 ● list of events (4) is empty;
 ● images in small preview windows (5) depend on 
current mode:

 ● video from specified board (boards) inputs – in this 
case camera icon is in windows captions (6); 

 ● storages content that corresponds to a zero time 
value, there is no camera icon in this case.

1

3

4

5

6

2

Note: More information on control elements of the main program window 
you can find in the «FDReplayMachine Console. Program Interface» 
section.
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Name and mark 
on the picture

Purpose State when 
program is launched

Time from start 
(1)

Indicates current 
period index (if 
mode of period 
counting is on) 
and playing time 
counted from start 
of period/game.

Counts time from the first 
program launch.

Indicators of the current position of video previewing:
Current Time 
(2)

Displays time that 
corresponds to the 
current position of 
video previewing.

Displays time of program 
start  
(daily time).

(from start) (3): There are 2 
elements that 
duplicate each 
other here: line 
with small numbers 
and indicator 
with larger 
numbers. The 
elements display 
playing time (time 
from start) that 
corresponds to 
current position of 
video previewing.

Displays 
00:00:00:00.

Current Event Displays 
information on 
event selected as 
current in the list: 
serial index, time 
mark.

Displays 
00:00:00:00.

2. If you want to change preview mode use one of the following 
ways: 
1. To display video from input lines press the Ctrl+I 
combination or the (7) button located on toolbar (the same is 
the View > Switch to Input Preview command). 

7 8

2. To display frames of video from storages press the Ctrl+T 
combination or the (8) button located on toolbar (the same is 
the View > Switch View Storages command).
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3. For a quick switching from one mode to another use the 
Tab key (the same is the View > Switch Between Input Preview/
View Storages command).

3.  Complete the following if it is necessary to start counting 
time from zero (reset it):

Note: We recommend to reset playing time before start of a game.

1. Click the Reset Start Time button (9) on toolbar (the same is 
the Edit > Reset Start Time command).

9

2. If it is necessary to take into account periods of game then 
put the Period (half, time) mark (10). Then select period in the 
list (11). 

Note: You can specify number of period by pressing key with a 
corresponding number on keyboard (1–9). Press 0 to refuse periods 
counting.

10 11

12

3. Click OK (12).
4. Timer is reset.  
Time is started again (13). If period is specified then its 
number is displayed on the current time indicator (14) (in 
the case if default settings are active). 

13

14
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During Game: Main Operator Actions

1. General Information
Operator works in the FDReplayMachine Console program 
window (more information you can find in the subsequent 
sections):

1. Operator creates (marks) events during game in a real time 
mode. 

Event is an important occurrence happened during the match 
that is specially marked by the operator. The event can be 
marked either directly after it has happened or later with the 
use of recorded material.

The application provides a possibility of marking the events 
and assigning them different types, for example, Goal or Viola-
tion. Events with types are marked with different colors (1). 
Parameters of marking are specified preliminary (see the 
«General Settings. Events» section).

All marked events are placed in the table. The table displays 
their characteristics: serial number, time and title. 

2. Operator customizes moments to be replayed later basing 
on marked events (camera, start of the event, etc.). Then he 
replays interesting moments when needed. 

3. Operator can customize playlist basing on marked events. 
Playlist is a set of interesting moments happened during the 
game. Operator can play this list operatively during break. 
Besides fragments of game he can also add some other video 
files to the list. More information on this issue see in the 
«FDReferee Workplace For Video Goal Judge. Record of 
match, mark and review of sport events» user’s guide, pp. 
30–48.

Different ways of marking events commands and control over 
replays are supported:

 ● via buttons and the main program menu:
 ● using mouse;
 ● touching buttons on the screen (if touch screen is 
used);

 ● via hot keys;
 ● via buttons, wheel and external console elements.
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http://www.softlab-nsk.com/forward/docs/en_fdreferee_guide.pdf
http://www.softlab-nsk.com/forward/docs/en_fdreferee_guide.pdf
http://www.softlab-nsk.com/forward/docs/en_fdreferee_guide.pdf
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2. Marking of Event When It Happens

1. Marking Without Type Indication

Note: You can observe current game (live video) via preview windows of the 
main program window (1) when mode of input video is on (Ctrl+I). 

Use one of the ways to mark event in a real time without 
indicating its type: 

 ● press Space on keyboard;
 ● click the Mark Event button (2) in the main program 
window;

 ● select the Events > Mark Event command in the (3) 
menu.

3

1

2

Line with a new event (4) is added to the list of events. When 
you marked event:

1. Its index is marked by green (5) as marked event becomes a 
current one.

2. Time when marked event has happened (6) is the same as 
playing time at the moment when the Mark Event command is 
executed.

3. Event is without name (7) as it is marked without type indicating. 
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9

8

4

5 6 7

4. Time of current preview position (8) is either the same as 
time when event has happened or some seconds back before 
it happens (from 0 up to 9 seconds, depending on current 
settings). If default settings are active then in 1 second before 
event is marked.

Note: Such automatic back shifting allows compensating time necessary 
for operator to mark event and find position the most close to start of 
interesting moment. It is useful for cases when necessary to broadcast 
repeat of event on air immediately. Besides it is convenient as the 
first frame is the frame that correpsonds to current position. 
Shifting time is specified in the General window on the Events tab (see 
the «General Settings. Events» section). Default value is 1 second.

5. The main program window (9) displays frame of  
video from current storage that corresponds to current position.
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2. Marking With Type Indication (Special Event)
Use one of the following ways to mark event with indicating its 
type (special event):

 ● press a corresponding button on a keyboard:
 ● B – «Goal»;
 ● N – «Danger»;
 ● M – «Violation»;
 ● < – special event «Other 1»;
 ● > – special event «Other 2»;

Note: Names of events are given for cases when default settings are active. 
To change the names and other parameters use the General 
Settings > Events window.

 ● select the Events > Mark Special Event ‘Name’ command, 
where Name is name of event.

Line with a new event (1) is added to the list of events. Its 
specified type is in the Event Title column. All other aspects are 
the same as in cases of marking usual events (see the above 
given paragraph, items 1, 2, 4, 5).
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3. Correction of Events

1. Correction of Current Event
1. Correcting allows changing time and/or type of current 

event. 
Current event indicator is an index with a green 
background (1). Index and time of current event are located 
in information field (2). 

1

2

3

4

2. Switch to mode of previewing of current position storages 
frames in one of the following ways:

 ● combination of the Ctrl+T buttons;
 ● clicking the (3) toolbar icon;
 ● via the View > Switch to View Storages menu command (4).

3. Double-click event line (5) in the list if event that you want 
to correct is not a current one.

Note: The recommendations are given for cases when default settings are 
active. You can change way of current event selection by single/double 
clicking in the Options > Events window. 

4. Current position (6) is moved to the point that correponds 
to event time. Preview windows (7, 8) display frames from 
storages. The frames correspond to current position of event 
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mark. Large preview window displays a current frame from 
the current storage.

5

7

8

9

6

5. Complete this step if you want to change time of current 
event. If you want to change only its type then pass to  
step 6.

 Specify moment that corresponds to new event mark by 
navigating recorded video material. Watch frames displayed 
in preview windows.

 Navigation is implemented via the buttons (9), mouse wheel 
or ways given in the table below. 
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Move menu 
command

Keyboard 
key

Button in the 
main applica-
tion window

Notes

Left one Step Moving one step left/right. 
Step is equal to 1 frame by default. 
Step is adjusted in the interface 
configuration window when necessary. Right one Step

Left some Frames Moving some frames left/right.
Dealing with default settings there is 
5-frames moving. 
Quantity of frames can be varied in the 
interface configuration window.

Right some Frames

0 Seconds Back 0 Moving specified number of seconds 
back from current event. There is no 
recurring moving when the button is 
pressed again.
For example, when 3 is pressed the 
frame located 3 seconds back from the 
current event mark is displayed in 
preview windows. If 0 is pressed then 
another frame (corresponding to event 
mark) is displayed.

1 Second Back 1

2 Seconds Back 2

3 Seconds Back 3

4 Seconds Back 4

5 Seconds Back 5

6 Seconds Back 6

7 Seconds Back 7

8 Seconds Back 8

9 Seconds Back 9

6. Select one of the commands in context menu (10) by  
right-clicking in events list:

 ● if you need to correct only time of event – Correct Cur-
rent Event, also:

 ● pressing the «/» key on the keyboard;
 ● clicking Correct in the main application window;
 ● selecting Events > Correct Current Event menu 
command;

 ● if you need to correct either type or type and time of 
event then – Correct Current Event to ‘Name’, Name denotes 
type of event. You can deal here with corresponding 
commands of the Event menu.
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10

7. Time that corresponds to event is changed (11).

11

2. Changing Type of Any Event
Complete the following to change type of event if it is not a 
current one. Complete the following for this:

1. Right-click event (1). Select the Edit This Event... command in the 
appeared context menu (2).
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1
2

2. Select necessary type of event in the Title/Type appeared 
drop-down list (3). Then click OK (4).

 

3

4

3. Type of event is changed.
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4. Adjusting and Launching of Replays

1. Brief Instruction
Complete the following to launch playback of replays (for more 
details see the subsequent section):

1. Select event necessary to be replayed. It can be the last  
marked event or event marked earlier.

2. Select storage which recorded material is to be replayed. 

3. Select the first replay frame. It can be a frame that 
corresponds to time of event mark or some other – several 
seconds or frames earlier/later the mark.

4. Set playback speed of replay: from – 100% up to + 200% 
relatively real speed.

5. Start playback of replay via the Start button. There are 2 
modes of replays playback: usual and delayed (via pause). 
When replay is playing you can prepare the next replay 
moment or mark other events.

6. Click Stop to stop replay and switch to input video viewing.

1

2

3 5 6

4
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2. Detailed Instruction

Note: Adjusting and launching of replay typically are implemented for event 
that has a current status. Current event indicator is event serial 
number on a green background (1). Index and time of current event 
are displayed in information field (2). 

1

2

1. Switch mode of storages navigation on by clicking the  
icon (1) located on a toolbar. Frames from storages (2) that 
correspond to current position are displayed in preview 
windows in this mode.

2

1

 You can also switch to storages navigation by pressing Ctrl+T 
or via the View > Switch to View Storages command.
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2. Select event to be replayed in the list with events by double-
clicking it (3). The event becomes current. Current position 
becomes a point that corresponds to time of this event.

Note: The recommendations are given for cases when default settings are 
active. You can change way of current event selection by single/double 
clicking in the General Settings > Events window.

5

3

4

Note: You can also select events using hot keys:
 PgUp is used to move to the previous event in the list and select it  
 as current one;
 PgDn is used to move to the next event in the list and select it as  
 current one;
 End is used to move to the last event in the list and select it as  
 current one.

3. Green frame (4) denotes that corresponding storage 
(camera) is current. Recorded material of this storage is 
played at slow motion replay later. 

 Click storage preview window to select another storage.

 Frames from current storage are displayed in a large 
preview window (5).

Note: You can also navigate storages using hot keys or via the Edit menu 
commands.
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                                                      Hot Keys

Hot key Used to select...

Z Camera 1
X Camera 2
C Camera 3
V Camera 4
A Camera 5
S Camera 6
D Camera 7
F Camera 8
Q Camera 9
W Camera 10

4. Select the first frame of replay. It can be a frame that 
exactly corresponds to time of event mark or some other – 
several seconds or frames earlier/later the mark.  
Use buttons of the main program window to move several 
frames back/ forward (6). 

Move some frames to the 
left (by default 5 frames)

Left one Step 
(by default 1 frame)  

Right one Step 
(by default 1 frame)  

Move some frames to the 
right (by default 5 frames)

6

Note: You can also move when selecting frame using hot keys or via the 
Move menu commands:

 – right 1 step;
 – left 1 step;

 – left some frames;

 – right some frames.

For more information on this issue see the «Navigating Storages» 
section below.
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5. Set speed of playback by clicking one of the buttons (7) or 
moving slider (8). Specified speed is displayed in information 
area (9). Click Reverse if you need to reverse playback.

7

9

10

8

Note: You can specify speed of replay playback (from – 100% up to + 200%) 
relatively real speed by assigning it to control speed buttons.

6. Launch playback of replay when needed by clicking 
Start (10). 

Note: Recommendations are given for cases when default playback mode is 
active. If the Start Paused mode is on then you must click Start again 
to broadcast replay moment. You can switch the mode on/off by check/
uncheck the Always Start Paused item of the Replay menu.

7. Playback of video from specified storage with specified speed 
starts. The first frame of replay corresponds to current 
position (11). Indicators in the main program window (12) 
display current state of replay. At this time you can prepare 
the next replay to play (steps 2–4) and, for example, to select 
another camera to replay material from.

8. You can change speed of playback at playing of material (if 
blocking of speed is off). You can prepare the next replay to 
playback by implementing steps 2–4 or, for example, select 
another camera.
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12

11

9. Replay is broadcasted till one of the buttons is pressed:
 ● Start (13) is used to start playback of the next replay 
moment;

 ● Stop (14) is used to stop replay, a passthrough video is 
passed to the output in this case.

13 14
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After a Game

1. Stop of Game Recording
1. Click the FDReplayCapture program icon (1) in Windows 

taskbar notification area.

1

Note: If solution you deal with is based on FD300 boards then the FDReplay 
VideoIn program is used to capture signal into storages. Two 
instances of the program can be launched depending on quantity of 
signals (VideoIn #1 and VideoIn #2 shortcuts). 

2. Click Stop (2) in the appeared window.

2

3. Click OK (3) in the appeared window.

3

4. Click Exit (4). Program window is closed.

4
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2. Adding of New Event Later Real Time
Complete the following to create event later when it has 
happened, for example, when game is finished: 

1. Switch to viewing of video from storages mode via one of the 
following ways:

 ● using Ctrl+T;
 ● clicking icon on toolbar (1);
 ● the View (2) > Switch to View Storages command. 

3

4

2

1

2. Preview windows (3) display frames that correspond to 
current position in storages. Indicator (4) displays time of 
current position with a frame accuracy.

3. Specify time position where to put mark for a new event 
navigating recorded material forward/back. Watch frames in 
preview windows. 

 For example, use the Move > Go to Time... (Ctrl+G) command or 
buttons of the main program window (5).

 All ways of navigating storages you can find in the 
«Navigating Storages» section below. 
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5

4. Complete one of the following actions when necessary to 
create new event:

 ● press Ctrl+R;
 ● use the Events > Create new Event command.

5. New event without type indication (6) is added to the list.

Note: Marks for several events (more than one) can not be put in one time 
position in storages. If event with the same time was already created 
a message on if you want to overwrite created event or not appears. 

6
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6. Right-click event (7) to specify its type. Select the Correct 
Current Event to ‘Name’ command, Name is a name of event. 

7

8

7. Type of event is changed (9). 

7

Note: You can also deal with the Edit this Event or Edit Current Event 
command to change type of event. 
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3. Creation of Video Report
Video report is created via the FDReplayMachine Console 
program.

 g  Tip: We recommend creating video report right after the match has 
finished.

Video report is a set of video files with recorded fragments of 
the match. The fragments correspond to marked events.

Every marked event is assigned to several different fragments 
recorded by every camera.

Event mark
Fragment start Fragment end

Fragments of the marked event recorded 
by different cameras

...

Record by Camera 1 ......

Record by Camera 2 ......

Record by Camera N ......

All fragments have equal duration by default. User specifies 
start and end of the fragment relatively event mark location. 
Duration of every fragment can be adjusted by changing its 
start and/or end.

You may output fragments in the following ways:
 ● every fragment is output into a separate video file;
 ● all fragments are output into one video file.

To adjust and record video report into file open the Playlist 
window using the Edit > Playlist Editor... command (Ctrl+P). 

Prepare a list of fragments for recording, then click Export 
button in the Playlist window to adjust exporting parameters and 
record video report into file(s). 

More information on working in the Playlist window see in the 
«FDReferee Workplace For Video Goal Judge. Record of match, 
mark and review of sport events» user’s guide, pp. 30–48.

The section currently is under development.
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4. Finish Working with the FDReplayMachine Console Program
The application can be closed in one of the following ways:

 ● using the File > Exit menu command;

 ● using the  button located on the application title 
bar.
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Navigating Storages

1. Moving to Event
Double-click a corresponding line in events list (1) to move to 
necessary event. You can also use the Move menu commands 
or hot keys: Move to the last event (End), Move to the previous event 
(PgUp), Move to the next event (PgDown). 

1

Note: Double-click is used for navigating to mark of event if default settings 
are active. To change way of event navigating from double click 
to single click put the corresponding mark in the General Settings 
window, the Events tab (the Options/General settings menu).  
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Moving to event time is implemented. 

Current event is marked in the list by green (2). Information on 
current event (3) is displayed above the list: its serial number 
and time. 

5

4

3

2

Indicator of current position displays time that corresponds 
to mark of selected event (4) (while some other moving is not 
implemented). Preview windows (5) display pictures from 
different cameras that correspond to current position of time (if 
view storages mode is on). 

2. Moving to Necessary Time
To move to a desired time:

1. Execute the Move > Go to Time... menu command (Ctrl+G).

2. Select format of time presentation in the appeared window: 
absolute (daily) or playing (time from start) time using (1, 2) 
radio buttons.

3. If absolute time is selected then specify date (DD.MM.YYYY) 
and time (hr:min:sec:fr) in the fields (1).
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1

2

4

3

5

4. If time from start (2) is selected then specify its value 
(hr:min:sec:fr).

 Colour of field displays state of data in current storage at 
the specified time position. Possible variants are:

 ● red – passed moment of time is specified, time moment 
is outside current limits of storage (data is absent);

 ● green – passed moment of time is specified, data was 
recorded in storage, data is available for viewing and 
playback;

 ● cyan – time has not come yet, will be in future, data 
will be recorded possibly.

5. To adjust value specified at steps 3 or 4 you can use control 
elements from the Add/Substract Time group (3).

6. To move current position to specified time without closing 
window use the Move to Time button (4).

7. To move current position to specified time and close window 
click OK (5).  

3. Moving to Storage Border
Complete the following to move current position to the 
beginning (frames of the earlier recorded material) or at the end 
of storages (frames of the last recorded material):

1. Open the Storages Information window by clicking the (1) 
button located on a toolbar or via the File > Storages Informa-
tion... command.

5
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2. Click the Go to Begin button (3) to move to position with the 
oldest data in storage (2).  
Click the Go to End button (5) to move to position with the 
newest data in storage (4) .

2 4

5 63

3. Current position is moved to corresponding border.

4. Click Close (6) to return to the main program window.

4. Moving to Period Start
To move to start of period use the Move > Go to Period Begin > N 
command, where N is number of period (1–9) or corresponding 
buttons combinations – Ctrl+1, ..., Ctrl+9. 

The commands are available if mode of game periods usage is on.

5. Navigating Current Position Via Frames
To navigate frames use the Left one step/Right one step and Left some 
frames/Right some frames commands. 

The commands are executed by clicking the (1) buttons, the Move 
menu commands (2) or via hot keys. You can also navigate 
storages using mouse wheel.
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Move some frames  
to the left (↑)

Left  
one Step(←)

Right 
one Step (→) 

Move some frames  
to the right (↓)

1

2

The following steps are specified by default:
 ● Left one step/Right one step – 1 frame;
 ● Left some frames/Right some frames – 5 frames.

Note: 1. Size of steps in corresponding fields (1) can be changed in the Op-
tions > General Settings... > Interface window (the Options/ General 
Settings menu). 
2. To enable/disable navigation via mouse wheel and specify 
direction of wheel scrolling turn on/off marks (2).

1

2
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6. Navigating Several Seconds Back From Mark of Current Event
To navigate current position several seconds back (1–9) from 
mark of current event use the Move > X Seconds Back command 
(X is a number from 0 up to 9) or corresponding hot keys.

To return to position that corresponds to mark of current event 
use the 0 Seconds Back command.

Move menu 
command

Keyboard 
key

Notes

0 Seconds Back 0 Move specified number of seconds back. There won't be 
recurring moving when the button will be pressed again.
For example, when 3 is pressed the frame located 3 seconds 
back from the current event mark will be displayed in 
preview windows. If you click 3 again current position is 
not changed. If you click 2 position is switched to frame 
located in 2 seconds from event mark. If 0 is pressed then, 
another frame (corresponding to current event mark) will be 
displayed.

1 Second Back 1

2 Seconds Back 2

3 Seconds Back 3

4 Seconds Back 4

5 Seconds Back 5

6 Seconds Back 6

7 Seconds Back 7

8 Seconds Back 8

9 Seconds Back 9

7. Moving At Event Marking
At marking of event current position is automatically moved 
to event time, and time is adjusted to some value, with active 
default settings the value is 1 second before moment of marking 
event.
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Note: Use drop-down list in the Options > General Settings... > Events 
window to specify shift step.

 

Automatic shifting back allows compensating time needed for 
operator to mark event. In this case you move to the most close 
position of needed event at once. This is useful if you need to 
playback replay of event at once as the first frame of replay 
corresponds to current position.
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Working With Video Introductions

1. General Information
Short video introduction («intro») is a short video file that is 
displayed before playback of replay. There is a possibility to 
deal with different introductions at the beginning and between 
separate fragments of sequence of replays.  

Recommended duration of intros is from 0.15 up to 5 seconds, 
recommended format is AVI.

Note: You can select fragment of clip of desired duration if necessary. 
Playing of files in other formats (*.mpg, *.mov, etc.) is supported but 
is not recommended .

2. Customizing of Introductions
Video introduction files are usually customized before start of a 
game.

Complete the following to specify files and customize mode of 
playback:

1. Select the Options > Playback... menu item (1) in the main 
program menu. 

1

2. Pass to the Advanced tab (2) in the appeared window.
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2

5

6

7

8

3

4

9

3. Put the Enable Multiple Subsequent Replays mark (3) to allow 
playback sequence of replays. 

4. Use the (4) check boxes to activate or deactivate parameters 
that are general for all backgrounds:

 ● Check files and show error/warning messages denotes 
checking duration of specified files and displaying 
warning if their duration exceeds a recommended 
value (0.15–5 sec) or if file is absent;

 ● Show warning messages about format of files denotes 
warning if format of file is not AVI or it contains 
uncompressed video;

 ● Play sound in intro/ending (if sound is present in file) enables 
playing sound from file on air.

5. Three groups of elements (5–7) are used to enable/disable 
playback of corresponding introductions and specify files to 
play:

 ● (5) are elements for customizing of Intro Before Replay 
(sequence of replays);

 ● (6) are elements for customizing of Intro Between Re-
plays;

 ● (7) are elements for customizing of Ending After Replays 
(sequence of replays).

Note: You can enable/disable playback of intros via buttons of the main 
program window: Default Picture 1, Default Picture 2, etc.
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6. Click Apply (8) to apply made configuration without closing 
of the window or OK (9) to close the window with applying of 
made configuration.

All types of intros are customized identically. For example, 
to specify clip for intro and enable its playback complete the 
following:

1. Put the (1) mark. 

2

6

5

1

4
3

2. Click Browse... (2). Specify clip for introduction. 

3. A full path to the clip is displayed in (3) field, (4) displays 
clip duration. 

4. Put the (5) mark to select fragment of clip and click Trim... 
(6).

5. Specify desired fragment to be played in the appeared Trim 
Editor window by putting marks of fragment start and/or 
end:
1. To select clip position use slider (7) or step-by-step 
navigation buttons (8). Current position frame is displayed 
in preview window (9), indicator displays current position 
time (10).
2. Click corresponding button (11, 12) to put the  
MarkIn/MarkOut mark. 
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8

10

7

9

11 12

3. Specified fragment is marked by blue colour on slider (13). 
Its duration is displayed in information field (14).

15

14

13

4. Click OK (15) to apply the settings after selecting fragment. 

Note: More information on the Trim Editor utility see in the «FDOnAir. 
Additional Sections» guide.
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6. Duration of specified fragment is displayed in information 
line (16).

16

3. Control Over Introductions
1. Buttons to control over introductions are located in the 

main program window. The buttons are enabled (1) if 
corresponding clips are assigned to them (about assigning 
see the subsection above):

 ● Intro 1 – introduction before replays;
 ● Intro 2 – introduction between replays;
 ● Ending – introduction after replays.

2. The button is outlined in green (2) if playback of 
introduction is enabled. Click corresponding button once to 
enable/disable playing. 

1 2
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Overlaying Game Titles (Logotype)

The system privides with a possibility of displaying titles 
during replays, for example, to inform the audience that this is 
a replay (1). 

1

Complete the following to customize titles displaying:

1. Create title project in the FDTitleDesigner program 
preliminary (see the «FDTitle Designer. Creating Title 
Objects» guide). The project, for example, can contain the 
MovieList title element. This element specifies region where 
logotype is displayed, logotype itself, some desired effects.

 The MovieList title element allows displaying a sequence of 
static images and clips (see the «FDMovieListEditor. Task 
Editor For the MovieList Title Element» guide).

2. Select the Options > Playback command (1) in the 
ReplayMachine Console main program menu. 
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3. Pass to the Video tab (2) in the appeared window. 

4. Put the Show titles during replays mark (3).

5. Click Browse... (4) to specify title project (*.SLTitleProj).

2

3

6 5

4

6. Click Apply (5) to apply the settings without closing the 
window or click ОК (6) to apply the settings and close the 
playback settings window.

7. Title project is loaded. Now titles are displayed at replays.
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FDReplayMachine Console. Program Interface 

Main Program Window

1. Appearance
The main program window contains the complete set of 
commands for instant replays adjustment and control over 
instant replays in a real-time mode.

1

10

9

6

8

11

3
2

4

5

7

12

 Main Program Window. Control Elements:
1 – main menu; 2 – toolbar; 3 – playing time timer; 4 – indicators of current 
position and current event; 5 – list of events and buttons used to mark/
correct events; 6 – buttons used to change current position one/several steps; 
7 – windows to preview data from cameras/storages; 8 – window to preview 
data from current storage; 9 – current settings of previewing and playback of 
replays (board); 10 – buttons for specifying of speed of replay playback and 
buttons to switch intro clips on/off; 11 – buttons to launch/stop replays and 
replay indicators; 12 – status line
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2. Playing Time Timer
Timer (1) located in the main program window displays number 
of current period (if mode of periods counting is on) and time 
from start of period/game.

1

2

Timer can be reset at any moment. For this use the icon located 
on toolbar (2) or the Edit > Reset Start Time menu command. 

The Reset Start Time window appears. Click OK to reset time.

Note: At reseting of start time events list is cleared in any way excluding 
cases when switching to new period is implemented (the next period is 
specified).

1

3

4 5

2

Control Elements:
1 – switch counting of periods on/off; 2 – specify index of current period; 3 – 
enable/disable clearing of events list; 4 – apply settings and close the window; 
5 – close the window without applying settings.

Press corresponding button on keybord: 1–9 to specify number 
of period in the Reset Start Time window quickly. Press 0 to 
disable period counting.
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3. Indicators of Current Position
Information on current position is displayed via specific 
indicators located in the main program window:

 ● 1 – time that corresponds to current preview position 
(daily);

 ● 2 – playing time (time from start) that corresponds to 
current preview position;

 ● 3 – information on current event (specified in events 
list): serial number, time mark.

1

2

3

Note: Changing of current position in storages happens in the following 
cases:
1. When marking of event. Current position is switched to moment 
of event time specifying. The time is decreased in several seconds 
automatically (0–9). 
2. At selection of event via events list or command of switching to 
event. Finally current position is switched to time mark of specified 
event directly. 
3. When using buttons/commands of navigation: several frames left, 
several frames right, one step left, one step right, 0, 1, ..., 9 seconds 
back.
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4. Elements to Work With Events 

1. Table With Events List 
List with events marked by operator is displayed in the main 
program window in the form of a table. 

2 3 4

1

The table displays the following information on event:
 ●   mark (1) is indicator of status of video recording 
into storages for event time:

 ● blue indicator ( ) indicates that there is data in 
storage;

 ● red indicator ( ) indicates that old data is already 
rewritten by new data;

 ● serial number (2) is assigned when marking of event 
automatically;

 ● time of event, Period_hh:mm:sec.frames, from start (3) 
corresponds to moment when operator marked event;

Note: Format of time displaying in program window (up to frames/fractions 
of a second accuracy) can be selected in the Time group of elements of 
the General Settings > Labels window. 
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 ● type of event (4) is specified by operator at marking (or 
later): usual event, goal, dangerous moment, etc. Each 
type has its colour in addition.

Note: To specify other (not default) names of events types ant their colour 
indication use group of elements in the General Settings > Events 
window.

2. Current Event Indicator 
Current event is an event selected in the list with all events. Its 
number in the table is green (1). Above the table information on 
current event is displayed (2): number, time.

1

2
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3. Buttons to Mark and Correct Events
The Mark Event button (1) is used to mark event without type 
indicating in a real-time mode (more information on this issue 
see in the «Marking of Event At Its Happenning» instruction 
above). 

1 2

The Correct button (2) is used to correct time of current event 
by shifting time mark of event to current position (more 
information on this issue see in the «Correcting of Event Time» 
in instruction above).

5. Preview Windows
Several small preview windows (1) and one big preview window 
are available to preview video from storages in the main 
program window. An additional preview window can be also 
opened.

1

2
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1. Small Preview Windows 
Small preview windows display frames from corresponding 
storages or board inputs (from cameras) depending on current 
preview mode (see commands of switching video from inputs – 
storage video). Indicator of previewing of input video is an icon 
of camera under window (1). 

Quantity of small windows is equal to quantity of opened 
storages. To see to what input window corresponds to put 
mouse cursor on it. A tool tip with information appears (2):

 ● name of video input and name of storage – if preview 
video input mode is on;

 ● only nsme of storage – if previewing storages video 
mode is on. 

2
1

If frame around window is magenta it means that frame is not 
loaded yet.

Note: «Window–camera» correspondence appears after program launch. 
Select View > Autoselect Inputs for Small Video Preview to assigne 
storages for small preview windows according to current order. 
Storages/cameras are assigned for small preview windows according 
to current order specifed in the Open Multiple Storages – Replay Ma-
chine window (1). Order of storages in list (2) corresponds to order of 
their displaying in windows. 

2
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2. Large Preview Window 
Large preview window (1) displays frames from current storage 
that correspond to current position (2). 

Indicator of current storage is a green frame (3). To select 
storage as the current one click corresponding small 
preview window. If you want to select another storage click 
corresponding small preview window (or use hot keys, see the 
commands of the Edit > Select Camera 1–10 menu).

1

2

3

3. Additional Preview Window 
There is also a possibility to open additional preview window 
to view current frames from current storage using the View > 
Preview in Separate Window command. 
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4. Windows Size and Labels 

1. To customize size and location of preview windows use 
group of elements (1) in the General Settings... > Interface 
window (Options menu). You can also customize here 
parameters of displaying – interlacing and image aspect 
ratio correction.

1

2. To customize content, view and location of labels and other 
service information related to preview windows use group of 
elements in the General Settings... > Labels window (2) (Options/
General Settings menu). 

2
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6. Elements To Control Replays Speed and Direction
Group of buttons located in the main program window (1) and 
slidebar (2) are used to specify speed of replay playback (you 
can use Replay > Set Speed XX% commands of the Replay menu 
also). Also, there is indicator of current speed (3) and the Re-
verse button (4) used to change direction of playback without 
changing of speed absolute value.

The buttons are active both before start of replay playback and 
during playback (if locking of speed is not on). Possible values 
for buttons and commands:

 ● –100% up to 0% – slow reverse replay («time is 
reversed»);

 ● 0% – stop frame;
 ● 0% – 100% – slow replay («time goes frontwords»);
 ● 100% – real speed;
 ● 100% – 200% – accelerated replay. 

4

1

3
2

5

 

The Lock Speed button (5) is used to lock speed when one replay 
is played. If the button is pressed then speed is not changed 
until the next Start command. 

Note: To assign some other speed values for buttons and commands use the 
group of elements (1) in the General Settings > Interface window  
(Options menu). 
Also you can customize time interval of changing speed starting 
from current one to specified one for each of four buttons (2). Buttons 
located in the main program window are numbered up–down. The 
supreme button (100% by default) is 1st, the lowest one (0%) – 4th.

2
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1

2

7. Buttons To Control Intros
See the «Control Over Introductions» section.

8. Control Elements and Replays Indicators

Note: See the «During Game: Main Operator Actions» section, subsection 4 
«Adjusting and Start of Replays».

State of replays is displayed in the main program window on  
2 indicators (1).

1
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Both indicators function in the same way. One of them indicates 
current state of replay, the second one – replay that follows the 
first one (if there is such). If after launch of the second replay 
one more is prepard then the first (free) indicator is used to 
output information on it, «cycled scheme». 

Note: Presence of 2 indicators is useful when dealing with sequential 
replays. As during broadcasting of one replay another one can be 
prepared (adjusted and loaded into buffer) then there is a necessity to 
control states of both replays – current and next one.

Current state of replays is displayed on indicators via colour 
and text messages. Possible messages here:

 ● Stopped – replay playback is stopped;
 ● Prepare – data is being loaded;
 ● Ready – data is loaded into buffer, replay is ready to be 
broadcasted on air. Its playback starts after clicking 
Start button;

 ● Playback (speed XX) – replay is being performed with 
specified speed;

 ● Intro – introduction is being played;
 ● Error (Stop) – error occured, playback of replay is 
stopped.

You can monitor replay content only via external monitor or 
using FDPreview application.
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Main Menu

The main menu includes commands to customize and control 
replays playback and commands for configuration of some other 
working aspects. Part of the commands can be activated via 
icons of the toolbar or main program window buttons, hot keys. 

There is also a possibility to activate commands via external 
console.

Menu 
command

Hot key Button in the 
main applica-
tion window

Notes

1. File menu includes commands for customizing link with storages and displaying information 
on used storages.
Open... Ctrl+O Open storages (is implemented in a separate 

window). 

Storages 
Information

Shift+I Display information on opened storages: 
parameters and current state.

Exit Close program window.

2. Edit menu includes commands to reset time of start, select current camera and switch to playlist 
editing.
Reset Start Time Reset playing time and specify period 

number.

Select Camera 1 Z click the first 
small preview 
window (from 
left–right)

Select camera number 1.

Select Camera 2 X the same but 
2nd window

Select camera 2.

Select Camera 3 C the same but 
3rd window

Select camera 3.

Select Camera 4 V the same but 
4th window

Select camera 4.

Select Camera 5 A the same but 
5th window

Select camera 5.

Select Camera 6 S the same but 
6th window

Select camera 6.

Select Camera 7 D the same but 
7th window

Select camera 7.

Select Camera 8 F the same but 
8th window

Select camera 8.

Select Camera 9 Q the same but 
9th window

Select camera 9.

Select Camera 10 W the same but 
10th window

Select camera 10.

Playlist Editor Ctrl+P Open window to edit playlist.
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Menu 
command

Hot key Button in the 
main applica-
tion window

Notes

3. Move menu includes commands to navigate storages (changing of current position).
Go to Time... Ctrl+G Pass to necessary time moment (specify daily 

or playing time/time from start).
Go to Period Begin > 
1,2 ...9

Ctrl+1 – 
Ctrl+9

Pass to start of selected period.

Left One Step Move one step back (1 frame by default).

Right One Step Move one step forward (1 frame by default).

Left Some Frames Move several frames back (5 frames by 
default).

Right Some Frames Move several frames forward (5 frames by 
default).

Value of shift is specified in the General Settings window on the Interface page.
Swap Up/Down 
Keys

Swap action of «Up»/«Down» keys (↑/↓) 
(are assigned for the Left Some Frames/Right 
Some Frames commands).

Disable Left/Right 
Some Frames

Disable buttons of the main program window 
and items of menu for the Left Some Frames/
Right Some Frames commands.

Go to Last Event End Move to the last event and select it as current 
one.

Go to Previous 
Event

PageUp Move to event that is previous current and 
select it as current one.

Go to Next Event PageDown Move to the next event and specify it as 
current.

X Seconds Back 
(X is a number 
from 0 up to 9)

0, 1 ... 9 Move specified number seconds back from 
time of current event. 
Repeated action of command does not lead to 
repeat shift.

4. Events menu includes commands for marking, editing and correcting of events.
Mark Event Space Put mark for current event and add event to 

the list without type indicating.

Mark Special 
Event “Goal“

B Mark current moment as «Goal» and add 
event to the list.

Mark Special 
Event “Dangerous 
Moment“

N Mark current moment as «Dangerous Mo-
ment» and add event to the list.

Mark Special 
Event “Violation“

M Mark current moment as «Violation» and add 
event to the list.

Mark Special 
Event “Other 1“

< Mark current moment as «Other 1» and add 
event to the list.

Mark Special 
Event “Other 2“

> Mark current moment as «Other 2» and add 
event to the list.
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Menu 
command

Hot key Button in the 
main applica-
tion window

Notes

Mark Special 
Event “Other N“ 
(N is number from 
3 up to 6)

Mark current moment as «Other N» (N=3–6) 
and add event to the list.

Create New Event Ctrl+R Create new event for current position in 
storages. If event with the same time already 
exists then the second is not created. The 
command is used when it is needed to mark 
moment as event when it was not marked in 
a real-time mode. 

Edit This Event Edit event under mouse cursor where mouse 
cursor is put by adjusting its colour, type, 
etc. The command is accessible from context 
menu of events list. 

Edit Current Event E Edit settings of current event: type, colors, 
etc.

Correct Current 
Event

/ Shift mark of current event to position that 
corresponds to current position.

Correct Current 
Event To “Goal“

Ctrl+B Assign to current event the «Goal» type.

Correct Current 
Event To “Danger-
ous Moment“

Ctrl+N Assign to current event the «Dangerous Mo-
ment» type.

Correct Current 
Event To “Viola-
tion“

Ctrl+M Assign to current event the «Violation» type.

Correct Current 
Event To “Other 1“

Ctrl+< Assign to current event the «Other 1» type.

Correct Current 
Event To “Other 2“

Ctrl+> Assign to current event the «Other 2» type.

Correct Current 
Event To “Other N” 
(N is number from 
3 up to 6)

Assign to current event the «Other N» type 
(N=3–6).

Delete all Non-
Special Events

Delete all untyped events.

Clear Events List Delete all events in list.
Export Events 
From List

Create PostPlay clips in corresponding 
storages basing on events list. Information 
on clips is available in PostPlay Preview 
and FDOnAir programs (see corresponding 
guides).

Export Events to 
All Storages

Create PostPlay clips in all storages basing 
on events in list.

5.1. Replay menu includes commands for playback of replays. 
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Menu 
command

Hot key Button in the 
main applica-
tion window

Notes

Start Paused «+» 
(on 
additional 
keyboard)

Prepare to playback to start replay via the 
Start command.

Start Enter Start playback of replay.

Stop Esc, 
«-» 
(on 
additional 
keyboard) 

Stop playback of replay.

Always Start 
Paused

Ctrl+P Switch mode of replay start via pause on/off. 
If the mode is on then prepareing to playback 
is made by Start command. Only second Start 
command starts playback.

5.2. Replay menu also includes commands for customizing of speed of replays playback. Use the 
buttons to specify speed. 
Set Speed 100% F9 – for the first (numering starts from up to 

down) button, default – real speed;
Set Speed 50% F10 – for the second button, default – 50% from 

real speed;
Set Speed 25% F11 – for the third button, default – 25% from 

real speed;
Set Speed 0% F12 – for the fourth button, default – 0% from 

real speed.
Lock Speed Ctrl+L Switch on/off mode of preserving current 

speed. If the mode is on then speed is locked 
untill the next activated Start command.

6. View menu includes commands for customizing of appearance of the main program window: 
sizes and location of control elements. The commands allow adjusting work area to a concrete 
user taking into account characteristics of monitor. For example, dealing with example touch 
screen operator works clicking buttons located in the window and sometimes it is necessary to 
enlarge/minimize their size or offsets between the buttons.
Toolbar Show/hide toolbar.
Status Bar Show/hide status bar.
Preview in Sepa-
rate Window

Ctrl+U Open a separate additional preview window.

Main Window Pre-
view Size >

Specify size of the main preview window (in 
percents relatively initial size).

50% Ctrl+F1

25% Ctrl+F2

33% Ctrl+F3

10% Ctrl+F4

Arbitrary Open window with settings  
(Properties > General Settings... > Interface).

M
ai

n 
M

en
u



66

Menu 
command

Hot key Button in the 
main applica-
tion window

Notes

Controls Size Specify size of controls (in units relatively 
default size). 

-2 Units 2 units less;
-1 Unit 1 unit less;
0 (Default) initial size;
+1 Unit 1 unit more;
+2 Units 2 units more.
Offset Between 
Controls >

Specify offset between controls (in units 
relatively default size). 

-2 Units 2 units less;
-1 Unit 1 unit less;
0 (Default) initial size;
+1 Unit 1 unit more;
+2 Units 2 units more.
Reset Controls 
Size and Offset

Return to initial window appearance.

Show Input Pre-
view

Enable/disable displaying of input video in 
small preview windows.

Auto Show Pre-
view on Start

Display input video in small preview windows 
at program start automatically.

Switch to Input 
Preview

Ctrl+I Display images from board inputs in all small 
preview windows.

Switch to View 
Storages

Ctrl+T Display data from storages that correpond 
to current position in all small preview 
windows.

Switch Between 
Input Preview/View 
Storages

TAB Switch from current display mode to another 
in all small preview windows (input video – 
video from storage or vice versa).

Small Video Pre-
view Mode >

Switch from current image to another in one 
preview window (input video – video from 
storage or vice versa):

Preview Input 1 Ctrl+Z in the first window;
Preview Input 2 Ctrl+X the second;
Preview Input 3 Ctrl+C the third;
Preview Input 4 Ctrl+V the fourth;
Preview Input 5 – 
Preview Input 10

the same for windows 5–10 correspondingly.

Autoselect Inputs 
for Small Video 
Preview

Automatically select board inputs in small 
windows, capture application must be 
running.

7. Options menu commands are used to open windows with settings.
More information on this issue see in section 8. 

M
ai

n 
M

en
u



67

Menu 
command

Hot key Button in the 
main applica-
tion window

Notes

General Settings... F5 Customizing of general parameters: 
functional characteristics and interface 
elements; use of processors and priority; 
control over GPI signals.

GPI Console... F6 Customizing of external GPI console.
Playback... F8 Customizing of previewing and playback of 

replays parameters.
Help

About ReplayMa-
chine

Open window with information on the 
program.
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Interface Customizing

1. Language

 8  Important: You must restart the ReplayMachine Console program to 
change interface language. 

To select language (Russian/English):

1. Select the Options > General Settings... menu command (1).

2

2. Pass to the Interface tab (2) in the appeared window.

3. Select language (3). Click OK (4).

2

4

3

4. Service message appears. Click ОК (5) to close window with 
settings.

5

5. The main program window is closed. Language is changed.
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2. Information in Title Bar Area
Title bar information area (1) includes name of program, index 
of current storage and text specified by user (optionally).

1

To customize this information complete the following:

1. Select the Options > General Settings menu command (2). 

2

2. Pass to the Interface tab (3) in the appeared window.

67

4

3

5

3. Using radio buttons (4) select desired title mode. If 
necessary specify text to be displayed in title bar (5).

4. Click Apply (6) to apply the settings and OK (7) to close the 
window.

5. Information in title bar is changed (8).
8
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3. Logotype
To customize displaying of logotype in the main program 
window complete the following:

1. Select the Options > General Settings menu command (1).

2

2. Pass to the Interface tab (2) in the appeared window.

3. Put the Logotype mark (3). Click the (4) button and specify 
file with image. Nearly located field displays a full path to 
file with the image. Acceptable formats of images are: *.png, 
*.bmp, *.dib, *.jpg, *.tga.

 Size of image must not exceed 800x800 pixels. It is 
recommended to deal with pictures with size not larger than 
80x80 pixels.

56

3

2

4

4. Click Apply (5) to apply specified settings and OK (6) to close 
the window.

5. Logotype appears in the upper right corner of the main 
window (7).

7
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4. Size of Buttons and Preview Windows
Size of elements of the main program window and spacing 
among them can be adjusted to a concrete user and 
characteristics of used monitor. 

For example, when using touch screen it cam be necessary to 
enlarge or diminish size of buttons and spacing. In this case it is 
more convenient for operator to click the buttons on screen with 
fingers.

1. To change size of buttons and other control elements use the 
View > Controls Size submenu commands (1).

2. To change spacing use the View > Offset Between Controls 
submenu commands (2). 

3. To change size of small preview windows use  
the View > Cameras Video Preview Size submenu commands (3).

4. To change size of the main preview window use  
the View > Main Video Preview Size submenu commands (4).

1

4

2

3

5. To customize location of preview windows pass to the Inter-
face group of elements (5).
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5

It is possible to separate small preview windows in several rows 
if size of monitor allows it.

5. Displaying of Time
The section is currently under development.
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Default Settings

Pictures below show default settings.

D
ef

au
lt 

Se
tt

in
gs



74

Customizing of Working Mode

Note: The following programs are used to customize parameters of input/
output boards:

 ● for FD322, FD422, FD842, FDVrt boards – FDConfig2  
(see the guide);

 ● for FD300 board – FDConfiguration (see the guide).

Timing Via Board

 The following is recommended to organize a synchronous 
work of all «Forward Goalkeeper» system components:
1. Synchronize all used boards (FD300/FD322/FD422/FD842) in 
the system by specifying mode of genlock video sources (see 
corresponding guides for the FDConfiguration/FDConfig2 
programs).
2. Set current timing in the ReplayMachine Console 
program via one of the boards (more information see below).

 8  Important: We insistently recommend to customize program to get time 
from board. It minimizes discrepancy between data captured 
from boards. 

Complete the following to specify device for current timing:

 8  Important: When changing this setting timer in the ReplayMachine 
Console program is reset. List of events is cleared.

1. Select the Options > General Settings menu command (1).

2
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2. Pass to the Events tab (2).

3. In the Current Time group of elements:
1. Put the Get Current Time Basing on Board mark (3).
2. Select necessary board in the list (4).

5

5

4

6

2

Note: If there are several boards of one type in the system (for example, 
FD422 board) all of them receive serial numbers automatically. 
Numbering depends on location of boards in mother board slots. You 
can identify all boards by opening the FDConfig2 program window (for 
FD300 board – the FDConfiguration program) and examine all boards 
there.

4. Click Apply (5) just to apply the settings or OK (6) to apply 
the settings and close settings window.
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Preview Mode

Previewing of video when working with replays can be 
implemented in windows of the ReplayMachine Console 
program and via external monitor (if system configuration 
allows).

Note: For video previewing and playing replays different devices must be 
selected (different output lines of one board or outputs of different 
boards). If it is impossible then previewing via external monitor is 
impossible. 

Information on devices used for replays previewing and 
playback is displayed in information area (1). 

1

To specify mode and device for preview complete the following:

1. Select the General Settings... > Playback menu command (2).

2

2. Pass to the Video tab (3) in the appeared window.

3

4

6

5

3. To switch preview mode via external monitor on select Both 
Preview Window and FD Board (4). Then click Board Video Proper-
ties (5).
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Note: If the (6) mark is put then in case when it is impossible to preview via 
board a service message appears.

4. Select type of board (FDExt (FD322/FD422/FD842) or 
FD300) in the appeared window via radio buttons (7). 

7

9

10

11

8

5. Select output line in the drop-down list (8). Remember that 
previewing and playback require different devices strictly.

6. Put/release marks (9) to specify necessary mode of fields 
output at playback.

7. Customize playback board module (10) additionally if FD300 
board is used for previewing.
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8. Close windows with settings successively by  
clicking OK (11, 12).

12
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Specifying of Board for Replays Playback

Information on devices used for storages previewing and 
playback of replays is displayed in information area (1). 

To specify mode and device for replays playback:

1. Select the General Settings... > Playback menu command (1).

1

2. Pass to the Video tab (2) in the appeared window.

2

6

4

5

3

3. Select device for playback (output line or board) in the 
drop-down list (3). Remember that previewing and playback 
require different devices strictly.
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4. If necessary to switch to broadcasting of video from input of 
specified board automatically put the Show live video from input 
on Stop mark (4). If the mark is absent then the last frame is 
displayed after replay stop.

5. To enable/disable displaying of the first replay frame on the 
output when waiting of replay put/release the mark (5).

6. Click OK (6) to close the window and apply the settings.

Note: For more information see the «Data Buffer in Operative Memory» 
subsequent section.
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Data Buffer in Operating Memory

Data buffer is memory area used at playback of replays for 
a transitional getting of data located on PC hard disk. Time 
needed for system to react when changing replay playback 
speed depends on buffer capacity. The less is capacity the 
quicker is fulfilling of buffer by data and the result is – program 
is ready to playback. Using larger capacity buffer results into 
enlarging of time needed to react user commands (e.g. changing 
speed).

Selecting buffer capacity you must take into account PC 
features. For fast PCs you can specify not a very large capacity 
– 100 – 300 msec, for slow PCs – capacity must be enlarged up 
to 1000 msec. 

We recommend testing quality of replays playback in advance 
(before broadcasting on air) especially if minimal value is 
specified. It is necessary to be sure that breaks and any 
dragging during playback are absent. If there are still some 
breaks then enlarge buffer capacity by completing the following:

1. Select the Options > Playback menu command (1).

1

2. Pass to the Video tab (3) in the appeared window. D
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4

3

2

5

3. Select necessary value in the Fifo depth and change 
speed delay (ms) drop-down list (3).

4. Click Apply (4) just to apply the settings or OK (5) to apply 
the settings and close settings window.
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Use of Processors and Priority

Proper distribution of processors and selection of processes 
priority allows optimizing system performance.

 8  Important: System resources must be distributed properly. Privileged 
status of one task may result into capturing of all resources by 
one task. It leads to impossibility of execution of other tasks. 

To view current settings and adjust them if necessary complete 
the following:

1. Select the Options > General Settings menu command (1).

1

2. Pass to the Process tab (2).

6

5

2

3

4

7
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3.  Put corresponding marks to select necessary processors for 
ReplayMachine Console program (3) and for task of replay 
playback (4).

 8  Important: Incorrect distribution of CPU cores among applications leads to 
abrupt decreasing of PC performance.

4. Select priority of process execution in the (5) drop-down list.

5. Click Apply (6) just to apply the settings or OK (7) to apply 
the settings and close settings window. 
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Interaction With External Devices Via GPI

The Forward Goalkeeper system provides with a possibility of 
interacting control signals with external devices via GPI. 

Using GPI signals it is possible to organize control start and 
stop of replay according to operator commands via external 
mixer. It guarantees accuracy of inserting of replay in air. The 
system transmits signals to external console at start and stop of 
replay playback.

Complete the following to customize mode of interaction of 
system and external equipment via GPI:

1. Select the Options > General Settings menu command (1).

1

2. Pass to the GPI tab (2).
2

3

3. Use the Input Signals group of elements (3) to customize 
control over replays via external GPI commands. For 
example, to customize start of replays via GPI complete the 
following:
1. Put the Enable input GPI for ‘Start Replay’ command mark (4).
2. Select signal (5) and active state (6) in drop-down lists of 
the group. 

Note: Identifiers of GPI signals include COM port identificator via which 
signal passes (COM1, COM2, etc.), serial number (0/1) and indication 
of signal type – Input denotes input signal, Output denotes output 
signal.
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4

5

7

6

In the same way you can customize control over stop of 
replay playback via external command – Enable input GPI for 
‘Stop Replay’ command (7).

4. To customize transmitting of GPI signals to external devices 
at activating of Start and Stop commands use the Output 
Signals group of elements. For example, to enable signal at 
activating of Start command complete the following:
1. Put the Enable output GPI on ‘Start Replay’ command mark (8). 

8

9

11

12

10

2. Select identifier of signal (9) and active state (10) in near 
located lists. 
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5. To enable output of service messages if errors appear at GPI 
signals processing put the Show messages about errors when 
working with GPI ports mark (11).

6. Click OK (12) to apply the settings and close window.
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External Consoles

The «Forward Goalkeeper» system provides with a possibility 
of using external console when preparing and output of data on 
air. 

Console is a device with buttons, speed regulator and jog 
shuttle. The following console models are supported currently:

 ● DNF ST300;
 ● DPS Velocity Jog-4000;
 ● DPS Velocity Jog-5000;
 ● JLCooper ES-SloMo;
 ● JLCooper MCS-3;
 ● Shuttle Pro 2.

Buttons and other control elements can be customized to 
complete the following:

 ● mark event (important moment) for its further replay;
 ● quickly navigate video material (frame by frame or 
with jog-shuttle);

 ● correct event mark;
 ● select current camera;
 ● control replay playback speed;
 ● prepare for launch, start, stop of replay. 

More information on dealing with consoles you can find in the 
«ReplayMachine Console. Instant Replay Control».
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ForwardT Software set: description, download, documentation, solutions
http://www.softlab-nsk.com/forward/streaming.html

Support 
e-mail: forward@sl.iae.nsk.su

  forward@softlab-nsk.com

  

Forum 
http://www.softlab-nsk.com/forum (currently available in Russian only)

Additional Documentation
1. «FDPostPlayCapture. Application for Input of Video and Audio Data into PostPlay 
Storages, Dealing with Storages Using the FD322, FD422, FD842 Boards» User’s Guide.

2. «FDReferee Workplace For Video Goal Judge. Record of match, mark and review of 
sport events. User’s Guide».

3. «FDOnAir. Additional Sections» User’s Guide.

4. «FDTitle Designer. Creating Title Objects» User’s Guide. 

5. «FDMovieListEditor. Task Editor For the MovieList Title Element» User’s Guide.

6. «FDPreview. Program for Previewing of Audio and Video on Boards Inputs/Outputs» 
User’s Guide.
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